Certain requests failing
Incident Report for ProcedureFlow
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 16:14 UTC
Identified
We have identified the issue: delete draft change requests and discarding changes to drafts will fail or will be slow.

We are working on releasing a fix as soon as possible.
Posted Apr 20, 2020 - 15:35 UTC
Investigating
We are currently investigating an issue where certain requests are failing such as deleting flows, updating users, etc.
Posted Apr 20, 2020 - 15:08 UTC