Images not loading/uploading
Incident Report for ProcedureFlow
Resolved
From Amazon:

1:05 PM PDT Between 11:40 AM and 12:56 PM PDT we experienced throttling errors accessing Amazon S3 in the US-EAST-1 Region. This issue is resolved and the service is operating normally.
Posted almost 2 years ago. Sep 14, 2017 - 20:09 UTC
Update
From Amazon:

12:49 PM PDT We are now seeing recovery in the throttle error rates accessing Amazon S3. We have identified the root cause and have taken actions to prevent recurrence.
Posted almost 2 years ago. Sep 14, 2017 - 19:52 UTC
Update
From Amazon:

12:38 PM PDT We continue to work towards resolving the increased throttling errors for Amazon S3 requests in the US-EAST-1 Region. We have identified the subsystem responsible for the errors, identified root cause and are now working to resolve the issue.
Posted almost 2 years ago. Sep 14, 2017 - 19:42 UTC
Monitoring
We're receiving elevated errors relating to image uploads. Images may or may not load. Because our website (https://procedureflow.com) is also hosted on Amazon S3, it may or may not load. Our storage provider, Amazon S3, is having increased error rates. We'll be monitoring as Amazon works to fix this problem.

From Amazon:

11:58 AM PDT We are investigating increased error rates for Amazon S3 requests in the US-EAST-1 Region.
12:21 PM PDT We can confirm that some customers are receiving throttling errors accessing S3. We are currently investigating the root cause.
Posted almost 2 years ago. Sep 14, 2017 - 19:28 UTC