We are continuing to monitor for any further issues.
Posted Apr 23, 2025 - 09:57 UTC
Monitoring
We have completed all steps to fix this issue and are monitoring the results.
Posted Apr 23, 2025 - 09:56 UTC
Update
The data migration has completed. We are working through additional steps to use the new migrated data.
Posted Apr 23, 2025 - 09:23 UTC
Update
We are currently experiencing an issue where customers are unable to create change requests (or save drafts via the "old" UI). This is affecting all customers.
The issue is related to the database limit for storing changes in change requests. We’ve hit a threshold that prevents us from adding more records, which is causing an error in the user interface. There is no data loss of existing change requests.
Our team is actively working on fixing this. We are running a data migration in the background to increase the limit. We expect this data migration to be completed around 11 PM Eastern today and then will perform additional steps in our resolution plan. Unfortunately, until this issue is resolved, you will not be able to create new change requests/save new drafts.
We recognize that this situation has impacted your workflow, and we're taking steps to avoid similar issues in the future. We'll continue to provide updates here and share a postmortem once the issue is resolved.
If you have any questions, please contact us, and we can schedule a call to discuss further.
Posted Apr 22, 2025 - 19:55 UTC
Identified
The issue has been identified and a fix is being implemented. We will continue to share updates as they become available.
Posted Apr 22, 2025 - 17:13 UTC
Investigating
We are currently investigating an issue where change requests are sometimes not opening/saving.
Posted Apr 22, 2025 - 16:40 UTC
This incident affected: Application (https://app.procedureflow.com).