DNS issues
Incident Report for ProcedureFlow
Resolved
Our customers are no longer having DNS issues with ProcedureFlow so we are resolving this incident. We plan to provide a postmortem on our blog next week.
Posted over 1 year ago. Feb 23, 2018 - 15:07 UTC
Update
We are continuing to monitor this issue. We are seeing this issue resolved more customers. We'll provide another update by tomorrow (2018-02-23) by 11 AM Eastern.
Posted over 1 year ago. Feb 22, 2018 - 20:25 UTC
Update
We are continuing to monitor this issue. Some customers are still reporting they are having DNS issues. We'll provide another update by 4 PM Eastern.
Posted over 1 year ago. Feb 22, 2018 - 15:37 UTC
Monitoring
Our DNS provider has not been able to identify any problems with their service. We are still unaware of the exact problem and are continuing to monitor/investigate. We are starting to see this issue fixed for some of our customers.

If you're still experiencing this problem and you feel comfortable enough, you can change your DNS settings to use Google's public DNS servers (8.8.8.8 and 8.8.4.4) which are able to correctly resolve ProcedureFlow's DNS records.

We will provide an update tomorrow (2018-02-22) by 11 AM Eastern.
Posted over 1 year ago. Feb 22, 2018 - 00:22 UTC
Identified
We have identified that there may be a problem with our DNS provider (Amazon). We have a case open and will continue to provide more updates as we have more information. If you feel comfortable enough, you can change your DNS settings to use Google's public DNS servers (8.8.8.8 and 8.8.4.4) which are able to correctly resolve ProcedureFlow's DNS records.
Posted over 1 year ago. Feb 21, 2018 - 20:37 UTC
Investigating
We are currently investigating a problem where some customers are not able to access ProcedureFlow. We will provide an update as soon as we have more information.
Posted over 1 year ago. Feb 21, 2018 - 20:15 UTC