ProcedureFlow partially loading

Incident Report for ProcedureFlow

Postmortem

On February 13 at 12:54 PM Eastern, a new deployment was made to ProcedureFlow. Some customers loaded ProcedureFlow without any styles (CSS) applied – effectively making ProcedureFlow unusable. Not all customers were impacted by this issue, however, due to the geographically distributed nature of ProcedureFlow. By 1:34 PM Eastern this issue was fully mitigated and all customers were able to use ProcedureFlow again.

We identified that certain CSS files served by ProcedureFlow’s content delivery service were served with the same name but different content. This conflicted with ProcedureFlow’s Subresource Integrity protection, causing browsers to reject loading the CSS files. The CSS file names also include a hash of the content. When the contents of a file changes, so should the file name. But we identified an issue with a component used by ProcedureFlow to generate these hashes causing different content to lead to the same file name.

Although this issue is mitigated and resolved, we are planning to implement several checks that prevent this type of issue from happening again and will continue to improve the reliability and resiliency of our service.

We apologize for this disruption as we understand that ProcedureFlow is critical to your own operations. If you have any questions, please reach out to us: https://help.procedureflow.com/article/28-contact-us

Posted Feb 13, 2025 - 21:45 UTC

Resolved

This incident is resolved. We apologize for the inconvenience this has caused.
Posted Feb 13, 2025 - 18:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 18:39 UTC

Identified

ProcedureFlow is aware that it is loading, but not display pages correctly. We've identified the issue and are working towards a fix.
Posted Feb 13, 2025 - 18:20 UTC
This incident affected: Application (https://app.procedureflow.com).