Email deliverability issues
Incident Report for ProcedureFlow
Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 15:26 UTC
Identified
We are aware that some customers are unable to receive emails from ProcedureFlow for many features like invitations, password resets, etc. We have identified that only customers using the Proofpoint email protection service are affected by this issue. ProcedureFlow uses Amazon SES to send emails. Proofpoint is blocking most or all emails being sent from Amazon SES IPs (not just ProcedureFlow).

We are working directly with Amazon to escalate and resolve this issue with Proofpoint. We are also working to proactively identify customers that may be affected by this issue.

If you're not receiving emails from ProcedureFlow (such as password resets) and suspect you are affected by this issue: please ask your IT team to confirm they're using Proofpoint and to request that Proofpoint unblocks Amazon SES IPs.
Posted Feb 22, 2022 - 18:04 UTC
This incident affected: Application (https://app.procedureflow.com).