DNS resolution failures

Incident Report for ProcedureFlow

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 01:07 UTC

Monitoring

Our DNS provider (AWS) has implemented a fix. We are seeing signs of recovery and continue to monitor.
Posted Feb 10, 2026 - 22:46 UTC

Identified

Procedureflow has confirmed that there is global widespread DNS resolution failures impacting Procedureflow as well as services we rely on. We're actively working with our DNS provider (AWS) to resolve this issue. You may experience Procedureflow app and status page intermittently working.
Posted Feb 10, 2026 - 21:41 UTC

Investigating

We are currently experiencing global DNS resolution failures impacting our availability. The issue is related to upstream DNS infrastructure on AWS. Our team is actively investigating and working to restore normal operations. Further updates will be provided as we learn more.
Posted Feb 10, 2026 - 21:38 UTC
This incident affected: Application (https://app.procedureflow.com).