Scheduled maintenance is in progress. We will continue to provide updates as necessary.
Posted Apr 24, 2025 - 04:59 UTC
Update
We are aiming to start maintenance in approximately 2 hours on April 24 at 1 AM Eastern.
A pre-migration operation is taking longer than anticipated due to the previous incident involving a large data migration.
Posted Apr 24, 2025 - 03:12 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 02:17 UTC
Scheduled
Apologies, the maintenance is NOT currently in-progress we will update again around 11 PM Eastern.
Posted Apr 24, 2025 - 02:16 UTC
In progress
The start of scheduled maintenance is delayed due to ongoing effects from yesterday's incident. We will share updates as they become available.
Posted Apr 24, 2025 - 02:00 UTC
Update
The start of scheduled maintenance is delayed due to ongoing effects from yesterday's incident. We will share updates as they become available.
Posted Apr 24, 2025 - 01:56 UTC
Scheduled
On April 23, 2025 at 10 PM Eastern we will be performing database maintenance that is required by our infrastructure provider. During this maintenance, ProcedureFlow will be unavailable to all customers.
We expect the maintenance to be completed within 30 minutes; however, as always, there is a possibility that it may take longer. We will provide updates during the maintenance. If you have any questions, please contact us at help@procedureflow.com.
Posted Apr 04, 2025 - 19:55 UTC
This scheduled maintenance affected: Application (https://app.procedureflow.com).