Images not loading/uploading, and emails delayed
Incident Report for ProcedureFlow
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 28, 2017 - 23:07 UTC
Update
Image uploading, emails, and change notifications are working again as Amazon S3 services are restored.
Posted over 2 years ago. Feb 28, 2017 - 22:14 UTC
Update
Images are loading but image uploads are still failing. Emails and change notifications are still delayed because other Amazon services that rely on Amazon S3 are unavailable.

Update from Amazon:

Update at 1:12 PM PST: S3 object retrieval, listing and deletion are fully recovered now. We are still working to recover normal operations for adding new objects to S3.

Update at 12:52 PM PST: We are seeing recovery for S3 object retrievals, listing and deletions. We continue to work on recovery for adding new objects to S3 and expect to start seeing improved error rates within the hour.
Posted over 2 years ago. Feb 28, 2017 - 21:23 UTC
Monitoring
Amazon S3 is still unavailable (images, emails, change notifications, etc are still affected). Update from Amazon:

Update at 11:35 AM PST: We have now repaired the ability to update the service health dashboard. The service updates are below. We continue to experience high error rates with S3 in US-EAST-1, which is impacting various AWS services. We are working hard at repairing S3, believe we understand root cause, and are working on implementing what we believe will remediate the issue.
Posted over 2 years ago. Feb 28, 2017 - 19:58 UTC
Identified
Emails (such as password resets), and change notifications will be delayed until the problem with Amazon S3 is resolved. This is an update from Amazon:

We're continuing to work to remediate the availability issues for Amazon S3 in US-EAST-1. AWS services and customer applications depending on S3 will continue to experience high error rates as we are actively working to remediate the errors in Amazon S3.
Posted over 2 years ago. Feb 28, 2017 - 18:59 UTC
Monitoring
Our file storage provider, Amazon S3, is having increased error rates. We're receiving elevated errors relating to image uploads. Images may or may not load. Because our website (https://procedureflow.com) is also hosted on Amazon S3, it may or may not load. We'll be monitoring as Amazon works to fix this problem.

https://status.aws.amazon.com/
Posted over 2 years ago. Feb 28, 2017 - 18:19 UTC