ProcedureFlow unavailable
Incident Report for ProcedureFlow
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 21:30 UTC
Monitoring
ProcedureFlow has been restored for at least the last 30 minutes; we will continue to monitor.
Posted Nov 18, 2024 - 21:07 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2024 - 20:29 UTC
Investigating
ProcedureFLow is currently experiencing issues. We are currently investigating the root cause; we will provide an update when we know more.
Posted Nov 18, 2024 - 20:29 UTC
This incident affected: Application (https://app.procedureflow.com).