Network Connectivity Issues
Incident Report for ProcedureFlow
Resolved
We are now able to hit ProcedureFlow from central North America. We have concluded that there are multiple network related issues currently being addressed across the Internet (https://www.cloudflarestatus.com/). We will continue to monitor how these issues affect ProcedureFlow.
Posted over 4 years ago. Jul 01, 2015 - 01:16 UTC
Monitoring
Many websites from around the world are currently inaccessibly to certain geographic areas. We are keeping a close watch to see how this will affect ProcedureFlow customers. Currently areas east of Montreal seem to be able to access ProcedureFlow, while areas closer to central North America are having problems loading many different websites, including ProcedureFlow.

This could be an Amazon US East issue as well, which is our host provider. We will continue to monitor the situation and keep you informed with updates.
Posted over 4 years ago. Jul 01, 2015 - 00:58 UTC